summaryrefslogtreecommitdiff
path: root/dev-util/scanmem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/scanmem
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/scanmem')
-rw-r--r--dev-util/scanmem/Manifest5
-rw-r--r--dev-util/scanmem/metadata.xml11
-rw-r--r--dev-util/scanmem/scanmem-0.15.3.ebuild52
-rw-r--r--dev-util/scanmem/scanmem-0.16.1.ebuild56
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-util/scanmem/Manifest b/dev-util/scanmem/Manifest
new file mode 100644
index 000000000000..99ff25b5f511
--- /dev/null
+++ b/dev-util/scanmem/Manifest
@@ -0,0 +1,5 @@
+DIST scanmem-0.15.3.tar.gz 243150 BLAKE2B d9a218815163da31c191884268698ea8f4e12521c9f512deb850327fef44b0590d977906b4e4d48b8f15b5958523951a90fae2ace1c3a9db3f677249c706ced5 SHA512 7f14e8a129321d7e58651d7e98ab71e58926465c98d256226ef7803fa7e42ba8bbe0879da8173ad2659deb655c73338db27d832a264b429f740331aee1f6d4b7
+DIST scanmem-0.16.1.tar.gz 202133 BLAKE2B bb07234aaf1f93dba5f7feb0af0efcdadb7cd7cabfce2d62f19da01ba947cf9f4ba91024db2379e218b91953679a77080a4fa711ceaca659ac7b3f01645e3f93 SHA512 5e0a97e020a8a392aed75e2654cc6bcfad68590b9caab43444e57c3180be45ce1269f5acb02355bee57ff8bb5b9349b4f65e0fe96655206a812ea645796b153b
+EBUILD scanmem-0.15.3.ebuild 953 BLAKE2B d194393272643c6161875cf8c1d51dac45804eafa60c9e487b8fb201ec852670d71bd262de6d4bd29dd8cd894f0bf09696348ae4327d5e449b86c9417519e408 SHA512 58cef753e1603467e1f80544fad0c4ae0fe124a49c322a46c4c4efb31d30df082ba171eca2685533b5969b93371cff25ad4cba2724fdaebbe62d09a8b7ea8eef
+EBUILD scanmem-0.16.1.ebuild 989 BLAKE2B 7beff0a82c896dfae227c5081c69df3e4420c022a20322b27b4b0a2a2a1b33d4657cb8a11d64fc23240d3662ba2c19a2a9476b6052312619e00a20d5fd9d3a54 SHA512 3771f6c6fe69ac354b16dbc3bb89ed40ba112070dbf6a689b5100b400ffd5ac8611115728fc5dc43dbdd53c62232f4b9c725e3ab70cf569d35c0081fe813b95d
+MISC metadata.xml 317 BLAKE2B 6d3e5903daa28fe65c109b4a75c8e143a90b7a99095353bc440d41566e9f942f0e415b5561b220bf23fd8e1e0b658d298a6d49d8a442b66042b129c6ee60057f SHA512 44f1ccb76808c4bd5c2bdade165d0f32d68ca07fbec73b2c074ff5b486cb69df2b23cb619d590b5a15d1adfe2f444f2b91aad3f238b29c752aaad97b3a5616b0
diff --git a/dev-util/scanmem/metadata.xml b/dev-util/scanmem/metadata.xml
new file mode 100644
index 000000000000..0796a9ceda90
--- /dev/null
+++ b/dev-util/scanmem/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="gui">Enable the GameConqueror GUI</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">scanmem/scanmem</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/scanmem/scanmem-0.15.3.ebuild b/dev-util/scanmem/scanmem-0.15.3.ebuild
new file mode 100644
index 000000000000..036313e7dd56
--- /dev/null
+++ b/dev-util/scanmem/scanmem-0.15.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Locate and modify variables in executing processes"
+HOMEPAGE="https://github.com/scanmem/scanmem"
+SRC_URI="https://github.com/scanmem/scanmem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+DEPEND="sys-libs/readline:="
+RDEPEND="${DEPEND}
+ gui? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3
+ sys-auth/polkit
+ )"
+
+REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use gui && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i "/CFLAGS/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable gui)
+}
+
+src_install() {
+ default
+
+ if use gui ; then
+ docinto gui
+ dodoc gui/{README,TODO}
+ python_fix_shebang "${D}"
+ fi
+}
diff --git a/dev-util/scanmem/scanmem-0.16.1.ebuild b/dev-util/scanmem/scanmem-0.16.1.ebuild
new file mode 100644
index 000000000000..7c226726a1fc
--- /dev/null
+++ b/dev-util/scanmem/scanmem-0.16.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Locate and modify variables in executing processes"
+HOMEPAGE="https://github.com/scanmem/scanmem"
+SRC_URI="https://github.com/scanmem/scanmem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+DEPEND="sys-libs/readline:="
+RDEPEND="${DEPEND}
+ gui? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3
+ sys-auth/polkit
+ )"
+
+REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use gui && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i "/CFLAGS/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-readline
+ $(use_enable gui)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use gui ; then
+ docinto gui
+ dodoc gui/{README,TODO}
+ python_fix_shebang "${D}"
+ fi
+}