summaryrefslogtreecommitdiff
path: root/dev-util/runme/runme-2.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 23:23:25 +0000
commit8e95bde8579d855189ccca3e693b4e3792f136c2 (patch)
tree4202dc7a3017eba106e5c5c5a41bcb3d08281143 /dev-util/runme/runme-2.0.5.ebuild
parent25e5a6599437664a3eff8d9f8a966adc896e09e8 (diff)
gentoo auto-resync : 11:12:2023 - 23:23:25
Diffstat (limited to 'dev-util/runme/runme-2.0.5.ebuild')
-rw-r--r--dev-util/runme/runme-2.0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/runme/runme-2.0.5.ebuild b/dev-util/runme/runme-2.0.5.ebuild
new file mode 100644
index 000000000000..9af10cc64611
--- /dev/null
+++ b/dev-util/runme/runme-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+# fix these on every bump
+GIT_SHA=bed11d0ed538857f007c55d2ce70905a94111130
+GIT_SHA_SHORT=bed11d0
+VERSION=v${PV}-${GIT_SHA_SHORT}
+
+DESCRIPTION="Execute your runbooks, docs and READMEs"
+HOMEPAGE="https://runme.dev"
+SRC_URI="https://github.com/stateful/runme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+unset LDFLAGS
+
+src_compile() {
+ emake \
+ GIT_SHA="${GIT_SHA}" \
+ GIT_SHA_SHORT="${GIT_SHA_SHORT}" \
+ VERSION="${VERSION}"
+}
+
+src_install() {
+ dobin runme
+ einstalldocs
+}