summaryrefslogtreecommitdiff
path: root/dev-util/rr/rr-5.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-util/rr/rr-5.3.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-util/rr/rr-5.3.0.ebuild')
-rw-r--r--dev-util/rr/rr-5.3.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/rr/rr-5.3.0.ebuild b/dev-util/rr/rr-5.3.0.ebuild
new file mode 100644
index 000000000000..10707860b4ae
--- /dev/null
+++ b/dev-util/rr/rr-5.3.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+CMAKE_BUILD_TYPE=Release
+
+inherit cmake-utils linux-info python-single-r1
+
+DESCRIPTION="Record and Replay Framework"
+HOMEPAGE="https://rr-project.org/"
+SRC_URI="https://github.com/mozilla/${PN}/archive/${PV}.tar.gz -> mozilla-${P}.tar.gz"
+
+LICENSE="MIT BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="multilib test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ sys-libs/zlib
+ dev-libs/capnproto
+ ${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ sys-devel/gdb[xml]"
+# Add all the deps needed only at build/test time.
+DEPEND+="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-devel/gdb[xml]
+ )"
+
+RESTRICT="test" # toolchain and kernel version dependent
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="SECCOMP"
+ linux-info_pkg_setup
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i 's:-Werror::' CMakeLists.txt || die #609192
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} ; then
+ ewarn "Test suite fails under FEATURES=usersandbox (bug #632394). Skipping."
+ return 0
+ fi
+
+ cmake-utils_src_test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -Ddisable32bit=$(usex !multilib) #636786
+ )
+
+ cmake-utils_src_configure
+}