summaryrefslogtreecommitdiff
path: root/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild')
-rw-r--r--dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
index 484e133e8ea0..725ccaf60ba1 100644
--- a/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
+++ b/dev-util/rosinstall_generator/rosinstall_generator-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -24,7 +24,7 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="test"
RDEPEND="
>=dev-python/catkin_pkg-0.1.28[${PYTHON_USEDEP}]
@@ -32,4 +32,9 @@ RDEPEND="
dev-python/rospkg[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --with-coverage || die
+}