summaryrefslogtreecommitdiff
path: root/dev-util/rosinstall/rosinstall-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/rosinstall/rosinstall-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/rosinstall/rosinstall-9999.ebuild')
-rw-r--r--dev-util/rosinstall/rosinstall-9999.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-util/rosinstall/rosinstall-9999.ebuild b/dev-util/rosinstall/rosinstall-9999.ebuild
deleted file mode 100644
index 34fc06b21e2a..000000000000
--- a/dev-util/rosinstall/rosinstall-9999.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
-HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
- dev-python/rosdistro[${PYTHON_USEDEP}]
- >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/bzr
- dev-vcs/mercurial
- app-shells/zsh
- )
-"
-
-python_test() {
- # From travis.yml
- # Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
- # Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
- # Set the bzr user
- bzr whoami "Your Name <name@example.com>"
- # command to run tests
- # Local tests work even if ros.org is down
- export ROSINSTALL_SKIP_PYTHON3=1
- nosetests test || die
-}