summaryrefslogtreecommitdiff
path: root/dev-util/rocm_bandwidth_test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/rocm_bandwidth_test
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/rocm_bandwidth_test')
-rw-r--r--dev-util/rocm_bandwidth_test/Manifest6
-rw-r--r--dev-util/rocm_bandwidth_test/files/4.3.0-use-proper-delete-operator.patch31
-rw-r--r--dev-util/rocm_bandwidth_test/metadata.xml11
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild22
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.0.2.ebuild26
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/Manifest b/dev-util/rocm_bandwidth_test/Manifest
new file mode 100644
index 000000000000..e774d96bf0ff
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/Manifest
@@ -0,0 +1,6 @@
+AUX 4.3.0-use-proper-delete-operator.patch 1201 BLAKE2B d1ca41918c625a0927ff4a687b0ef90e8f33bc2474d5a97b049ce3d3757af926470bd388c2d9db5d554a0f7010552b82ab16a576a91ebb91a02ae6cccb2a8d77 SHA512 c581fb71b6e734a4ebb8249a929464e89b84e12dc5e859e284c42b917356839ccaebda845f79abda5ace1f7578cc99f335c9d313a9c9e61eab737c01e67d2e01
+DIST rocm_bandwidth_test-4.3.0.tar.gz 37965 BLAKE2B e4689c4a11257aecf98a0a047dcb56bc23deb8e781d819488c9c934ee2ea6914f0de49a48f09c3895383f715659ff750c0fb2bbf3ec136350d935bd159d2237b SHA512 8c646cbb736ab50bf25302566436cda9acb496a639453ae35235de34ec5ace1cc1a5a1544eb3482114386c9f8b850d4572e2eef6884c7cab50e9a4b6b37f67c0
+DIST rocm_bandwidth_test-5.0.2.tar.gz 38091 BLAKE2B bf9767d55a3400fa1bc95a638a9fd6debcd3b0cd8f5d698eb5d39568c5dc7321c5a63c6678b4bc91f7bd5ff9cee13da7800b3a7523a24a0ceae607be8b18b0b4 SHA512 b235838442dd12e0283b36168eed4853094f423b8b61e3f623be78133af9f89406fb83254972d5a622f90998450660165205deb95082cb49907f112f4de80942
+EBUILD rocm_bandwidth_test-4.3.0.ebuild 555 BLAKE2B b3b4b13e7115b7adf3b64e4559ef5be3961197c5824ee4f8518614e56c0789017e149b0ea3402b1c46f54459a8e2587e6fca69413d0eb392470b550668fed55c SHA512 7d934e3a9a50ac55c75d6e5443197b427ec7807595dcc7b29fe7bdb6479d8f3a83ebe30081ae8e4d175bcbb9b37bb4900752d5eea96a95743c295385a02896f2
+EBUILD rocm_bandwidth_test-5.0.2.ebuild 579 BLAKE2B ae0e1842fbde4eb70c38e5787b5f370d5e0176c986a8a725c2b14062b41c9a5060ee7f674b055addd46dd263d5caaf1eb6d1ab25e2a69dded2c37c062ad59d63 SHA512 c1d92789d07e80c1cfe1bc54f329c183223cb165baf8efec4384738cfb8d99e95e579c101ce756e6b62b6db4a6a52a6ade4bcaac1e7f5bc5ee3642a608c9d317
+MISC metadata.xml 338 BLAKE2B 5cb4452f4f4b4d4af05fdf3a487d18d970b300fd36466bac36fcdea5b77a7c71efafcf6edfdc5e041bb484f0eb7bac694689db1663ece9260cb8c10d799949ef SHA512 dab4e8519c431bfa40fb174851106f51d79ded92e9fd40a9478689fce70c9c8bab75ea595e099faf3d1ec990071c50e2a0793c1697850b745c14d0b5b59d03bf
diff --git a/dev-util/rocm_bandwidth_test/files/4.3.0-use-proper-delete-operator.patch b/dev-util/rocm_bandwidth_test/files/4.3.0-use-proper-delete-operator.patch
new file mode 100644
index 000000000000..d5a2998b3979
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/files/4.3.0-use-proper-delete-operator.patch
@@ -0,0 +1,31 @@
+From 964e03c013c6827cfa3f6ca0bed81b77d1884b40 Mon Sep 17 00:00:00 2001
+From: Michael Klemm <michael.klemm@amd.com>
+Date: Mon, 7 Jun 2021 16:55:46 +0200
+Subject: [PATCH] Fix issue #73 by using the proper delete[] operator
+
+---
+ rocm_bandwidth_test_report.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/rocm_bandwidth_test_report.cpp b/rocm_bandwidth_test_report.cpp
+index 8895705..d4a0f60 100755
+--- a/rocm_bandwidth_test_report.cpp
++++ b/rocm_bandwidth_test_report.cpp
+@@ -341,7 +341,7 @@ void RocmBandwidthTest::DisplayCopyTimeMatrix(bool peak) const {
+ double* perf_matrix = new double[agent_index_ * agent_index_]();
+ PopulatePerfMatrix(peak, perf_matrix);
+ PrintPerfMatrix(false, peak, perf_matrix);
+- free(perf_matrix);
++ delete[] perf_matrix;
+ }
+
+ void RocmBandwidthTest::DisplayValidationMatrix() const {
+@@ -349,7 +349,7 @@ void RocmBandwidthTest::DisplayValidationMatrix() const {
+ double* perf_matrix = new double[agent_index_ * agent_index_]();
+ PopulatePerfMatrix(true, perf_matrix);
+ PrintPerfMatrix(true, true, perf_matrix);
+- free(perf_matrix);
++ delete[] perf_matrix;
+ }
+
+ void RocmBandwidthTest::DisplayDevInfo() const {
diff --git a/dev-util/rocm_bandwidth_test/metadata.xml b/dev-util/rocm_bandwidth_test/metadata.xml
new file mode 100644
index 000000000000..37913a6924f6
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>xgreenlandforwyy@gmail.com</email>
+ <name>Yiyang Wu</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild
new file mode 100644
index 000000000000..4d6aa988c9e9
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:${SLOT}"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}/4.3.0-use-proper-delete-operator.patch" )
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.0.2.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.0.2.ebuild
new file mode 100644
index 000000000000..6353571d9ac8
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:${SLOT}"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}