summaryrefslogtreecommitdiff
path: root/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
commit4161fa7d1be6dac96e36f8ed343f234a8ef3a74f (patch)
treeee6d7260a8c03fb6191fead616b7dd50f07a7aa4 /dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
parentef4d67f1907798e309efed58d673fd60594a14a8 (diff)
gentoo auto-resync : 20:12:2022 - 13:51:21
Diffstat (limited to 'dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild')
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
new file mode 100644
index 000000000000..094ed9071adb
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}