summaryrefslogtreecommitdiff
path: root/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild')
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild
new file mode 100644
index 000000000000..4d6aa988c9e9
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-4.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:${SLOT}"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}/4.3.0-use-proper-delete-operator.patch" )
+
+S="${WORKDIR}/${PN}-rocm-${PV}"