summaryrefslogtreecommitdiff
path: root/dev-util/rizin/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
commit83b5cde41ddb8fd20de4536dd68eb08da42d013e (patch)
tree6a993cfe0eb5a8024c508e9f6a6de02538f7c52e /dev-util/rizin/files
parent9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (diff)
gentoo auto-resync : 17:07:2022 - 20:32:17
Diffstat (limited to 'dev-util/rizin/files')
-rw-r--r--dev-util/rizin/files/rizin-0.3.0-typedb-prefix.patch132
-rw-r--r--dev-util/rizin/files/rizin-0.3.2-never-rebuild-parser.patch36
2 files changed, 0 insertions, 168 deletions
diff --git a/dev-util/rizin/files/rizin-0.3.0-typedb-prefix.patch b/dev-util/rizin/files/rizin-0.3.0-typedb-prefix.patch
deleted file mode 100644
index dfb86447df71..000000000000
--- a/dev-util/rizin/files/rizin-0.3.0-typedb-prefix.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-https://github.com/rizinorg/rizin/issues/1789
-
-Signed-off-by: Florian Märkl <info@florianmaerkl.de>
-
-diff --git a/test/unit/test_serialize_analysis.c b/test/unit/test_serialize_analysis.c
-index 51092c067..0d714ba90 100644
---- a/test/unit/test_serialize_analysis.c
-+++ b/test/unit/test_serialize_analysis.c
-@@ -546,7 +546,10 @@ Sdb *vars_ref_db() {
- }
-
- bool test_analysis_var_save() {
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- RzAnalysis *analysis = rz_analysis_new();
- rz_analysis_use(analysis, "x86");
- rz_analysis_set_bits(analysis, 64);
-diff --git a/test/unit/test_type.c b/test/unit/test_type.c
-index d8a3d9c5f..3956a800b 100644
---- a/test/unit/test_type.c
-+++ b/test/unit/test_type.c
-@@ -379,7 +379,10 @@ static bool test_enum_types(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -417,7 +420,10 @@ static bool test_const_types(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -469,7 +475,10 @@ static bool test_type_as_string(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -516,7 +525,10 @@ static bool test_array_types(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -569,7 +581,10 @@ static bool test_struct_func_types(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -659,7 +674,10 @@ static bool test_struct_array_types(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -707,7 +725,10 @@ static bool test_struct_identifier_without_specifier(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -735,7 +756,10 @@ static bool test_union_identifier_without_specifier(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
-@@ -767,7 +791,10 @@ static bool test_edit_types(void) {
- RzTypeDB *typedb = rz_type_db_new();
- mu_assert_notnull(typedb, "Couldn't create new RzTypeDB");
- mu_assert_notnull(typedb->types, "Couldn't create new types hashtable");
-- const char *dir_prefix = rz_sys_prefix(NULL);
-+ const char *dir_prefix = getenv("RZ_PREFIX");
-+ if (!dir_prefix) {
-+ dir_prefix = rz_sys_prefix(NULL);
-+ }
- rz_type_db_init(typedb, dir_prefix, "x86", 64, "linux");
-
- char *error_msg = NULL;
diff --git a/dev-util/rizin/files/rizin-0.3.2-never-rebuild-parser.patch b/dev-util/rizin/files/rizin-0.3.2-never-rebuild-parser.patch
deleted file mode 100644
index 0f5586c0023d..000000000000
--- a/dev-util/rizin/files/rizin-0.3.2-never-rebuild-parser.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 9bcfa2a6d3eaa5df00ae728c44811faf08effbd3
-Author: John Helmert III <ajak@gentoo.org>
-Date: Thu Jan 6 11:12:58 2022 -0600
-
- shlr/rizin-shell-parser/src: Never rebuild parser.c
-
- This requires dev-libs/tree-sitter[ts-cli] and net-libs/nodejs, both
- of which would be heavy new dependencies. However, these are only
- needed to rebuild the already-existing tree-sitter parser, which
- doesn't do much for us (if anything) since it already exists. In this
- case, it's better to just reduce fragility by unconditionally
- disabling this.
-
- Bug: https://bugs.gentoo.org/830068
- Signed-off-by: John Helmert III <ajak@gentoo.org>
-
-diff --git a/shlr/rizin-shell-parser/src/meson.build b/shlr/rizin-shell-parser/src/meson.build
-index 0171183ae0..81dcc13b33 100644
---- a/shlr/rizin-shell-parser/src/meson.build
-+++ b/shlr/rizin-shell-parser/src/meson.build
-@@ -1,14 +1,4 @@
--tree_sitter_bin = find_program('tree-sitter', required: false)
--node_bin = find_program('node', required: false)
--if tree_sitter_bin.found() and node_bin.found() and tree_sitter_dep.type_name() != 'internal'
-- parser_c = custom_target('parser_src_c',
-- command: [tree_sitter_wrap_py, tree_sitter_bin, '@OUTDIR@/..', '@INPUT@'],
-- input: [grammar_js],
-- output: 'parser.c',
-- )
--else
-- parser_c = files('parser.c')
--endif
-+parser_c = files('parser.c')
-
- shell_parser_files = [files('scanner.c'), parser_c]
- shell_parser_inc = [platform_inc, include_directories('tree_sitter')]