summaryrefslogtreecommitdiff
path: root/dev-util/repo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/repo
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/repo')
-rw-r--r--dev-util/repo/Manifest3
-rw-r--r--dev-util/repo/metadata.xml11
-rw-r--r--dev-util/repo/repo-1.12.37.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/repo/Manifest b/dev-util/repo/Manifest
new file mode 100644
index 000000000000..237989c70f5c
--- /dev/null
+++ b/dev-util/repo/Manifest
@@ -0,0 +1,3 @@
+DIST repo-1.12.37.tar.gz 115098 SHA256 31e374155eba54b18fae966ef3fb9290378c29fd8c15085cc70e8007a3227c66 SHA512 3ff6b5c3bcc8fba1861102035b86b59137e7dcebeab7a0fb01672da28473e1912c3cbac7c085e9b8d3fce404bd18095ba022d4978d83833f666bd31d621d5953 WHIRLPOOL 5025f0fb2b2fe84ddbfdc4d8585243ac80276f1906f50bf878a2c804cfdb357973c9d6ac282338c366f3cbdee74ccafaa80d69a16ab8b9dbbf00b8ac07e97376
+EBUILD repo-1.12.37.ebuild 781 SHA256 b245c36658ab50eb4f6b2c76b02ec39d2769cb10f61ad1b5ed09d7b34d5e9984 SHA512 87ba2cd9cff189e4c945747fb16b730b1bf6b5235d22aa92ee72ef2395c053c7d875629786225b4e9686a7279f49f06584f7f8482c70e533318085f67388ee13 WHIRLPOOL c57e446e9dfb43a8dd3a795d5b381ec24178af90dd03c540c45409893901a105f1e4faf522ff706e284c219b93ffe94f1bc4e1ad2b042e9b18a3c60d2718c617
+MISC metadata.xml 387 SHA256 ab968c1c0971ec6907d3136c98f694eb0abd279e7a160513c299eba2036977b6 SHA512 25be1dab3058fe3d823c1a0863c9894bf5c7d8020c0faeab73db09cde992589eda83f36ea718396e327bfb18627a58f2db2fc3d21e2f1d490d91ebe867d33dee WHIRLPOOL a81d0d3da45e6117d882894c05b2174f03a6287f7b10e5d5e6cb8ef80e1c7dc9c468beec73f0d5e1a4e327c50e5d228ffe7bacf4828868a9a921b890ad851b8c
diff --git a/dev-util/repo/metadata.xml b/dev-util/repo/metadata.xml
new file mode 100644
index 000000000000..e31c816a429f
--- /dev/null
+++ b/dev-util/repo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <longdescription>
+ Tool for managing multiple git repositories. From Google, useful for building Android.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/repo/repo-1.12.37.ebuild b/dev-util/repo/repo-1.12.37.ebuild
new file mode 100644
index 000000000000..ba92c75316c3
--- /dev/null
+++ b/dev-util/repo/repo-1.12.37.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# 3.x is currently very buggy, only 2.7 actually works
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://android.googlesource.com/tools/repo"
+# Should be:
+#SRC_URI="https://android.googlesource.com/tools/repo/+archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~wizardedit/dist/repo-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ python_foreach_impl python_fix_shebang ./repo
+ python_foreach_impl python_doexe ./repo
+}