summaryrefslogtreecommitdiff
path: root/dev-util/repo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/repo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/repo')
-rw-r--r--dev-util/repo/Manifest3
-rw-r--r--dev-util/repo/metadata.xml11
-rw-r--r--dev-util/repo/repo-1.12.37.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/repo/Manifest b/dev-util/repo/Manifest
new file mode 100644
index 000000000000..ffc6fc64d7a2
--- /dev/null
+++ b/dev-util/repo/Manifest
@@ -0,0 +1,3 @@
+DIST repo-1.12.37.tar.gz 115098 BLAKE2B 7a54afad5a3355edfab09be62c6881b4c0d3bc521c04313bb1dd428fc7a1c9a82a65186d20fd05d67227c88d2f6a30fd70f53f35dbfc0b6e7e668252ce6fbd9d SHA512 3ff6b5c3bcc8fba1861102035b86b59137e7dcebeab7a0fb01672da28473e1912c3cbac7c085e9b8d3fce404bd18095ba022d4978d83833f666bd31d621d5953
+EBUILD repo-1.12.37.ebuild 801 BLAKE2B 8fe1e4ded31323b6631687429f66c5cb255255deb0271a9bd4c2bff3bf84bf25a4c691976031e7c584ca1a277d410a5a196abcd59012b7623070c4e2910aebe3 SHA512 7605c9427efcec6eec5b89165fd821ceea4a7234cf15c94187f8a890f8565e9dc1a7b3dde4836c285571cce207a3806235ac3d35c60c2c084b69ba9304b55aad
+MISC metadata.xml 387 BLAKE2B 78c64cb9d80402907983723261bc49e4429c0c3be69ea93b06090bd4c7d64b0289a6cdb52cee1fd867c2e2460b59a92a5605126ff3faa1fe7816edae54a2d33d SHA512 25be1dab3058fe3d823c1a0863c9894bf5c7d8020c0faeab73db09cde992589eda83f36ea718396e327bfb18627a58f2db2fc3d21e2f1d490d91ebe867d33dee
diff --git a/dev-util/repo/metadata.xml b/dev-util/repo/metadata.xml
new file mode 100644
index 000000000000..e31c816a429f
--- /dev/null
+++ b/dev-util/repo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <longdescription>
+ Tool for managing multiple git repositories. From Google, useful for building Android.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/repo/repo-1.12.37.ebuild b/dev-util/repo/repo-1.12.37.ebuild
new file mode 100644
index 000000000000..7ee57ac5ba7c
--- /dev/null
+++ b/dev-util/repo/repo-1.12.37.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# 3.x is currently very buggy, only 2.7 actually works
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://android.googlesource.com/tools/repo"
+# Should be:
+#SRC_URI="https://android.googlesource.com/tools/repo/+archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~wizardedit/dist/repo-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ python_foreach_impl python_fix_shebang ./repo
+ python_foreach_impl python_doexe ./repo
+}