summaryrefslogtreecommitdiff
path: root/dev-util/repo/repo-1.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-util/repo/repo-1.13.2.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-util/repo/repo-1.13.2.ebuild')
-rw-r--r--dev-util/repo/repo-1.13.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/repo/repo-1.13.2.ebuild b/dev-util/repo/repo-1.13.2.ebuild
new file mode 100644
index 000000000000..1123c98edd31
--- /dev/null
+++ b/dev-util/repo/repo-1.13.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# 3.x is currently very buggy, only 2.7 actually works
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://android.googlesource.com/tools/repo"
+# Should be:
+#SRC_URI="https://android.googlesource.com/tools/repo/+archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~dlan/distfiles/repo-${PV}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ python_foreach_impl python_fix_shebang ./repo
+ python_foreach_impl python_doexe ./repo
+}