summaryrefslogtreecommitdiff
path: root/dev-util/rebar-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/rebar-bin
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/rebar-bin')
-rw-r--r--dev-util/rebar-bin/Manifest6
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.13.2.ebuild31
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.6.2.ebuild8
3 files changed, 39 insertions, 6 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
index 4b75cc19bf16..9b518ad0488b 100644
--- a/dev-util/rebar-bin/Manifest
+++ b/dev-util/rebar-bin/Manifest
@@ -1,3 +1,5 @@
-DIST rebar3 694889 BLAKE2B 3a8f5562a0c984caf5d7b3ba1063a90bf110a60cea316eaf88f5199b890e186f85193dc0302b36dc31051d3552912c8d1582f563f989df97ee28364a3f47512a SHA512 8fb5c7737d70fc7a706b1e124ab660550e8637da9258338016ab2e260f1c6d662548ef723705cd18210050d052e79945578623d9e9892e08dbfdb9cb04fd89fb
-EBUILD rebar-bin-3.6.2.ebuild 590 BLAKE2B f9d0ca1c49a545709d17665e9872aee34f9a06d2c9711b5d0e701017c1b7e812ef7ff035ead1482640add65db692b8611900d62932ba5109aff766c140b755ec SHA512 725fb4d99ea3848e4a643714c01c4a7efc3230967df2bb8eef69069243e937c578ab21fc5a73a151339089761b4bd581fbf1990299d6b553d8ebe7ff902a1912
+DIST rebar-bin-3.13.2 839684 BLAKE2B f7aab86b015549bb13a7fe2b3b0c64fc6b8383f46adef2fd50a080983a411f936d1c416be60eac70a2ea72439831c9a5e0e85381168ca973d6fcfbfa198e0987 SHA512 33cb7b083cd0e90159e06d6b21c1e8047cc5a2d49c469ae15449fefb8576427f2088977a294c677548f0543eb06cb25ad4c165e8df4b373e3562a7adc6125a94
+DIST rebar-bin-3.6.2 694889 BLAKE2B 3a8f5562a0c984caf5d7b3ba1063a90bf110a60cea316eaf88f5199b890e186f85193dc0302b36dc31051d3552912c8d1582f563f989df97ee28364a3f47512a SHA512 8fb5c7737d70fc7a706b1e124ab660550e8637da9258338016ab2e260f1c6d662548ef723705cd18210050d052e79945578623d9e9892e08dbfdb9cb04fd89fb
+EBUILD rebar-bin-3.13.2.ebuild 601 BLAKE2B 61e55196804a2eb904108d36ce183fcaff72eb0cf67006256015df7e2ca5bb2972bb5188fc50526679fcb5312caba1c58833388d201bcd4d8ac0ff4648d49ffe SHA512 60cbeb39494490552b18114d11c3db68d4e82c01986b4303522ec3e481f5dfaa6fe6e2e690ec6fe8a8613b31a7114466a625853c1bb38ee6cada505c311d1d1c
+EBUILD rebar-bin-3.6.2.ebuild 601 BLAKE2B 61e55196804a2eb904108d36ce183fcaff72eb0cf67006256015df7e2ca5bb2972bb5188fc50526679fcb5312caba1c58833388d201bcd4d8ac0ff4648d49ffe SHA512 60cbeb39494490552b18114d11c3db68d4e82c01986b4303522ec3e481f5dfaa6fe6e2e690ec6fe8a8613b31a7114466a625853c1bb38ee6cada505c311d1d1c
MISC metadata.xml 939 BLAKE2B 3d451a472d9986f1aee67c4ede6ddc28d56cac865e0fd0a33f957f3007126d47d7cb3bf87916abca0be68138c167b138d884b38da65ca26d4dab79e42b839c58 SHA512 6e6e0a14df5031fee427dc518e0b69cafca6b8dcc429fa8cbcecacf78a1a56796c9cc6a545a6e9506a752e749c06a4ef7cf4cdb889ef2c6ca53bcf0f68fa363b
diff --git a/dev-util/rebar-bin/rebar-bin-3.13.2.ebuild b/dev-util/rebar-bin/rebar-bin-3.13.2.ebuild
new file mode 100644
index 000000000000..4f7f563c355f
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.13.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
+}
+
+src_install() {
+ dobin rebar3
+}
diff --git a/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
index 9835d50cdf22..4f7f563c355f 100644
--- a/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
+++ b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,10 +9,10 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
HOMEPAGE="https://github.com/erlang/rebar3"
-SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3"
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
LICENSE="Apache-2.0"
-SLOT="3"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-lang/erlang"
@@ -23,7 +23,7 @@ S="${WORKDIR}"
QA_PREBUILT="/usr/bin/rebar3"
src_unpack() {
- cp -v "${DISTDIR}/${A}" "${S}/" || die
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
}
src_install() {