summaryrefslogtreecommitdiff
path: root/dev-util/ragel/ragel-6.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-util/ragel/ragel-6.10.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-util/ragel/ragel-6.10.ebuild')
-rw-r--r--dev-util/ragel/ragel-6.10.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-util/ragel/ragel-6.10.ebuild b/dev-util/ragel/ragel-6.10.ebuild
index 8c0d3bba3196..00b8d07df42b 100644
--- a/dev-util/ragel/ragel-6.10.ebuild
+++ b/dev-util/ragel/ragel-6.10.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils autotools autotools-utils
+inherit autotools
DESCRIPTION="Compiles finite state machines from regular languages into executable code"
HOMEPAGE="http://www.colm.net/open-source/ragel/"
@@ -12,26 +12,26 @@ SRC_URI="http://www.colm.net/files/ragel/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="vim-syntax"
-
-DEPEND=""
-RDEPEND=""
# We need to get the txl language in Portage to have the tests :(
-RESTRICT=test
+RESTRICT="test"
DOCS=( ChangeLog CREDITS README TODO )
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_test() {
cd "${S}"/test
./runtests.in || die
}
src_install() {
- autotools-utils_src_install
+ default
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins ragel.vim
- fi
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
}