summaryrefslogtreecommitdiff
path: root/dev-util/qbs/qbs-1.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-30 10:08:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-30 10:08:01 +0100
commit97b6af3d234a8e2f0a40851cb5701b3172cdbf63 (patch)
tree46170bc4077ce9e1435c4e80ae2e0d6185e3190c /dev-util/qbs/qbs-1.19.1.ebuild
parent4c2ed878d2353b3decc88b86f66017cdee3ceeeb (diff)
gentoo auto-resync : 30:08:2023 - 10:08:01
Diffstat (limited to 'dev-util/qbs/qbs-1.19.1.ebuild')
-rw-r--r--dev-util/qbs/qbs-1.19.1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/qbs/qbs-1.19.1.ebuild b/dev-util/qbs/qbs-1.19.1.ebuild
index 3339bb574287..28e160fd13ed 100644
--- a/dev-util/qbs/qbs-1.19.1.ebuild
+++ b/dev-util/qbs/qbs-1.19.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -58,11 +58,15 @@ src_prepare() {
echo "SUBDIRS = $(usev test auto)" >> tests/tests.pro
# skip several tests that fail and/or have additional deps
- sed -i \
- -e 's/findArchiver(binaryName,.*/"";/' `# requires zip and jar` \
- -e 's/p\.value("nodejs\./true||&/' `# requires nodejs, bug 527652` \
- -e 's/\(p\.value\|m_qbsStderr\.contains\)("typescript\./true||&/' `# requires nodejs and typescript` \
- tests/auto/blackbox/tst_blackbox.cpp || die
+ local SKIP_TESTS_ARGS=(
+ # requires zip and jar
+ -e 's/findArchiver(binaryName,.*/"";/'
+ # requires nodejs, bug 527652
+ -e 's/p\.value("nodejs\./true||&/'
+ # requires nodejs and typescript
+ -e 's/\(p\.value\|m_qbsStderr\.contains\)("typescript\./true||&/'
+ )
+ sed -i tests/auto/blackbox/tst_blackbox.cpp "${SKIP_TESTS_ARGS[@]}" || die
sed -i -re '/blackbox-(android|apple|java)\.pro/ d' tests/auto/auto.pro || die
}