summaryrefslogtreecommitdiff
path: root/dev-util/pscan/pscan-20000721-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/pscan/pscan-20000721-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/pscan/pscan-20000721-r1.ebuild')
-rw-r--r--dev-util/pscan/pscan-20000721-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/pscan/pscan-20000721-r1.ebuild b/dev-util/pscan/pscan-20000721-r1.ebuild
new file mode 100644
index 000000000000..11c078d3650b
--- /dev/null
+++ b/dev-util/pscan/pscan-20000721-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit toolchain-funcs
+
+DESCRIPTION="A limited problem scanner for C source files"
+HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
+# I wish upstream would version their files, even if it's only with a date
+SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+# Does NOT contain a testsuite, but does contain a test.c that confuses src_test
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS}" || die
+}
+
+src_install() {
+ newbin pscan printf-scan || die
+ dodoc README find_formats.sh test.c wu-ftpd.pscan || die
+}