summaryrefslogtreecommitdiff
path: root/dev-util/promu/promu-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 05:45:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 05:45:30 +0100
commit16c48ec5caa018c82b1db0f23542c29893f9b919 (patch)
tree89f2ea54d4d61a56db2fdc3a19bceb72f60eda08 /dev-util/promu/promu-0.15.0.ebuild
parentca52870b45c298a446df20ae15d12bff5f37c480 (diff)
gentoo auto-resync : 02:10:2023 - 05:45:30
Diffstat (limited to 'dev-util/promu/promu-0.15.0.ebuild')
-rw-r--r--dev-util/promu/promu-0.15.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/promu/promu-0.15.0.ebuild b/dev-util/promu/promu-0.15.0.ebuild
new file mode 100644
index 000000000000..36b0779a8ac2
--- /dev/null
+++ b/dev-util/promu/promu-0.15.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/prometheus/promu.git"
+else
+ SRC_URI="https://github.com/prometheus/promu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://github.com/rahilarious/gentoo-distfiles/releases/download/${P}/deps.tar.xz -> ${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+LICENSE="Apache-2.0"
+LICENSE+=" BSD BSD-2 MIT"
+SLOT="0"
+
+RESTRICT+=" test"
+DOCS=(
+ "doc/examples"
+ "README.md"
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ if [[ ${PV} == *9999 ]]; then
+ dobin "${PN}"
+ else
+ newbin "${P}" "${PN}"
+ fi
+ einstalldocs
+}