summaryrefslogtreecommitdiff
path: root/dev-util/pretrace/pretrace-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-util/pretrace/pretrace-0.4-r2.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-util/pretrace/pretrace-0.4-r2.ebuild')
-rw-r--r--dev-util/pretrace/pretrace-0.4-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/pretrace/pretrace-0.4-r2.ebuild b/dev-util/pretrace/pretrace-0.4-r2.ebuild
new file mode 100644
index 000000000000..c6ff1edc5859
--- /dev/null
+++ b/dev-util/pretrace/pretrace-0.4-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1
+
+DESCRIPTION="start dynamically linked applications under debugging environment"
+HOMEPAGE="https://github.com/robholland/pretrace"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOC_CONTENTS="Remember to execute ptgenmap after modifying pretrace.conf"
+
+PATCHES=(
+ "${FILESDIR}"/${P}--as-needed.diff
+ "${FILESDIR}"/${P}-build.patch #227923
+ "${FILESDIR}"/${P}-qa.patch
+)
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man3 /usr/share/man/man8
+ emake DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" PREFIX="${D}/usr" VERSION="${PVR}" install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}