summaryrefslogtreecommitdiff
path: root/dev-util/ply/ply-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-06 07:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-06 07:06:03 +0000
commitaeb00d494a88844a67a5483be221169c5cc2c4be (patch)
tree31cadd24d79954c602995af6abb621e764729674 /dev-util/ply/ply-2.3.0.ebuild
parent1c646fe0f6db3b97a61ac9d93f96c0eee5ef517a (diff)
gentoo auto-resync : 06:03:2024 - 07:06:02
Diffstat (limited to 'dev-util/ply/ply-2.3.0.ebuild')
-rw-r--r--dev-util/ply/ply-2.3.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/ply/ply-2.3.0.ebuild b/dev-util/ply/ply-2.3.0.ebuild
index d6512d640f1a..ba9de28027fe 100644
--- a/dev-util/ply/ply-2.3.0.ebuild
+++ b/dev-util/ply/ply-2.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info
+inherit autotools flag-o-matic linux-info
DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
HOMEPAGE="https://github.com/iovisor/ply"
@@ -34,6 +34,18 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858458
+ # https://github.com/iovisor/ply/issues/92
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
rm -f "${ED}/usr/share/doc/${P}/COPYING"