summaryrefslogtreecommitdiff
path: root/dev-util/ply/ply-2.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/ply/ply-2.1.1-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/ply/ply-2.1.1-r1.ebuild')
-rw-r--r--dev-util/ply/ply-2.1.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/ply/ply-2.1.1-r1.ebuild b/dev-util/ply/ply-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..995c760e574e
--- /dev/null
+++ b/dev-util/ply/ply-2.1.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
+HOMEPAGE="https://github.com/iovisor/ply"
+SRC_URI="https://github.com/iovisor/ply/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/iovisor/ply/commit/1bc183af8703023e377f92716ecd3f339ffffd11.patch -> ${P}-arm-build-fix.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc"
+IUSE="static-libs"
+# Bug 733248 file collisions with sys-boot/plymouth:
+# /usr/lib64/libply.la
+# /usr/lib64/libply.so
+RDEPEND="!sys-boot/plymouth"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
+ ~BPF_JIT ~HAVE_BPF_JIT ~BPF_EVENTS"
+
+ check_extra_config
+}
+
+src_prepare() {
+ sed -i "/^AC_INIT/c\AC_INIT(${PN}, ${PV}," configure.ac || die
+ eapply "${DISTDIR}/${P}-arm-build-fix.patch"
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -f "${ED}/usr/share/doc/${P}/COPYING"
+
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.a' -delete || die
+ fi
+}