summaryrefslogtreecommitdiff
path: root/dev-util/perf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/perf/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/perf/files')
-rw-r--r--dev-util/perf/files/perf-4.1.5-prefix.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/perf/files/perf-4.1.5-prefix.patch b/dev-util/perf/files/perf-4.1.5-prefix.patch
new file mode 100644
index 000000000000..0c4dff011306
--- /dev/null
+++ b/dev-util/perf/files/perf-4.1.5-prefix.patch
@@ -0,0 +1,43 @@
+commit 75e84ab906ef8935cff3df3d8929f1bafea81599
+Author: Lukas Wunner <lukas@wunner.de>
+Date: Thu Jun 18 13:00:32 2015 +0200
+
+ perf tools: Fix build breakage if prefix= is specified
+
+ Invoking Makefile.perf with prefix= breaks the build since Makefile.perf
+ hands that variable down to Makefile.build where it overrides
+
+ prefix := $(subst ./,,$(OUTPUT)$(dir)/)
+
+ leading to errors like this:
+
+ No rule to make target '/usrabspath.o', needed by '/usrlibperf-in.o'
+
+ Signed-off-by: Lukas Wunner <lukas@wunner.de>
+ Acked-by: Jiri Olsa <jolsa@kernel.org>
+ Cc: David Ahern <dsahern@gmail.com>
+ Fixes: c819e2cf2eb6f65d3208d195d7a0edef6108d5
+ Link: http://lkml.kernel.org/r/5582c48a.84a22b0a.a918.5285SMTPIN_ADDED_MISSING@mx.google.com
+ Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+
+diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
+index 10df572..98cfc38 100644
+--- a/tools/build/Makefile.build
++++ b/tools/build/Makefile.build
+@@ -94,12 +94,12 @@ obj-y := $(patsubst %/, %/$(obj)-in.o, $(obj-y))
+ subdir-obj-y := $(filter %/$(obj)-in.o, $(obj-y))
+
+ # '$(OUTPUT)/dir' prefix to all objects
+-prefix := $(subst ./,,$(OUTPUT)$(dir)/)
+-obj-y := $(addprefix $(prefix),$(obj-y))
+-subdir-obj-y := $(addprefix $(prefix),$(subdir-obj-y))
++objprefix := $(subst ./,,$(OUTPUT)$(dir)/)
++obj-y := $(addprefix $(objprefix),$(obj-y))
++subdir-obj-y := $(addprefix $(objprefix),$(subdir-obj-y))
+
+ # Final '$(obj)-in.o' object
+-in-target := $(prefix)$(obj)-in.o
++in-target := $(objprefix)$(obj)-in.o
+
+ PHONY += $(subdir-y)
+