summaryrefslogtreecommitdiff
path: root/dev-util/patchelf/patchelf-0.17.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 05:50:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 05:50:43 +0000
commit3a60b38f14fa81df8e18aa67d1634fbffca17d14 (patch)
tree2db4eb443cdf196f01a18d0c053ff46d6bd5626d /dev-util/patchelf/patchelf-0.17.2.ebuild
parentea8740cede74808fe1546789e18738612217bb97 (diff)
gentoo auto-resync : 14:01:2023 - 05:50:42
Diffstat (limited to 'dev-util/patchelf/patchelf-0.17.2.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.17.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.17.2.ebuild b/dev-util/patchelf/patchelf-0.17.2.ebuild
new file mode 100644
index 000000000000..ef24854c8688
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.17.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}