summaryrefslogtreecommitdiff
path: root/dev-util/packer/packer-1.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-02 17:23:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-02 17:23:01 +0100
commite805507c58bab294dddb75f6fc9b551d9d92de86 (patch)
tree0ea187e6b9c02a5666b5b05c33691360d7c3cfca /dev-util/packer/packer-1.8.6.ebuild
parent4f39f95b585c2bd23d646439b444a8738b01d37e (diff)
gentoo auto-resync : 02:05:2023 - 17:23:00
Diffstat (limited to 'dev-util/packer/packer-1.8.6.ebuild')
-rw-r--r--dev-util/packer/packer-1.8.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.8.6.ebuild b/dev-util/packer/packer-1.8.6.ebuild
new file mode 100644
index 000000000000..5d2c7f38d9d4
--- /dev/null
+++ b/dev-util/packer/packer-1.8.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gentoofiles.s3.eu-central-1.amazonaws.com/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ ego build \
+ -mod=readonly \
+ -ldflags "${go_ldflags}" \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}