summaryrefslogtreecommitdiff
path: root/dev-util/oprofile/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/oprofile/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/oprofile/files')
-rw-r--r--dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch10
-rw-r--r--dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch30
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch b/dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch
new file mode 100644
index 000000000000..01fc86910a3a
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-1.1.0-gcc6-template-depth.patch
@@ -0,0 +1,10 @@
+--- oprofile-1.1.0/configure.ac.orig 2015-07-21 17:53:27.000000000 +0300
++++ oprofile-1.1.0/configure.ac 2016-11-22 01:15:31.329067697 +0300
+@@ -320,7 +320,6 @@
+ AX_CXXFLAGS_OPTION(OP_CXXFLAGS,[-Wall])
+ AX_CFLAGS_OPTION(OP_CFLAGS,[-fno-common])
+ AX_CXXFLAGS_OPTION(OP_CXXFLAGS,[-fno-common])
+-AX_CXXFLAGS_OPTION(OP_CXXFLAGS,[-ftemplate-depth-50])
+ AX_CFLAGS_OPTION(OP_CFLAGS,[-Wdeclaration-after-statement])
+
+ dnl enable option to use GCC test coverage
diff --git a/dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch b/dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch
new file mode 100644
index 000000000000..ab3ca7c1b142
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-1.1.0-gcc6.patch
@@ -0,0 +1,30 @@
+--- a/libop/op_alloc_counter.c
++++ b/libop/op_alloc_counter.c
+@@ -171,7 +171,7 @@
+ /* no counters then probably perfmon managing perfmon hw */
+ if (nr_counters <= 0) {
+ nr_counters = op_get_nr_counters(cpu_type);
+- unavailable_counters = (~0) << nr_counters;
++ unavailable_counters = (~0U) << nr_counters;
+ }
+
+ /* Check to see if we have enough physical counters to map events*/
+--- a/libutil++/op_bfd.cpp
++++ b/libutil++/op_bfd.cpp
+@@ -535,15 +535,13 @@
+ {
+ op_bfd_symbol const & sym = syms[sym_idx];
+
+- bool const verbose = cverb << (vbfd & vlevel1);
+-
+ if (anon_obj)
+ start = sym.vma();
+ else
+ start = sym.filepos();
+ end = start + sym.size();
+
+- if (!verbose)
++ if (!(cverb << (vbfd & vlevel1)))
+ return;
+
+ io_state state(cverb << (vbfd & vlevel1));