summaryrefslogtreecommitdiff
path: root/dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
commitba4938837d52c0aff763d8acdc03ce103dd3ff82 (patch)
tree377739d379f8040dc456a89b2347a8f2a83830c8 /dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild
parent3e3aa158fd100df495010eed7915f012d5c9bcaa (diff)
gentoo auto-resync : 24:12:2023 - 13:37:40
Diffstat (limited to 'dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild')
-rw-r--r--dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild b/dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild
new file mode 100644
index 000000000000..e31ba9edaf8a
--- /dev/null
+++ b/dev-util/opencl-headers/opencl-headers-2023.12.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="OpenCL-Headers"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unified C language headers for the OpenCL API"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-Headers"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}