summaryrefslogtreecommitdiff
path: root/dev-util/omake/omake-0.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-util/omake/omake-0.10.2.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-util/omake/omake-0.10.2.ebuild')
-rw-r--r--dev-util/omake/omake-0.10.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/omake/omake-0.10.2.ebuild b/dev-util/omake/omake-0.10.2.ebuild
index 46e34cdb6a51..d8f2abbc56cc 100644
--- a/dev-util/omake/omake-0.10.2.ebuild
+++ b/dev-util/omake/omake-0.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,8 @@ DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
readline? ( >=sys-libs/readline-4.3:0= )"
RDEPEND="${DEPEND}"
+RESTRICT="!ocamlopt? ( strip )"
+
src_prepare() {
epatch \
"${FILESDIR}/${P}-cflags.patch"
@@ -45,5 +47,4 @@ src_install() {
dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt
dohtml -r doc/html/*
fi
- use ocamlopt || export STRIP_MASK="*/bin/*"
}