summaryrefslogtreecommitdiff
path: root/dev-util/meson/meson-0.48.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-util/meson/meson-0.48.2.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-util/meson/meson-0.48.2.ebuild')
-rw-r--r--dev-util/meson/meson-0.48.2.ebuild37
1 files changed, 32 insertions, 5 deletions
diff --git a/dev-util/meson/meson-0.48.2.ebuild b/dev-util/meson/meson-0.48.2.ebuild
index d7d772117ac9..0c58e4314099 100644
--- a/dev-util/meson/meson-0.48.2.ebuild
+++ b/dev-util/meson/meson-0.48.2.ebuild
@@ -9,20 +9,47 @@ if [[ ${PV} = *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
fi
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Open source build system"
HOMEPAGE="http://mesonbuild.com/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-util/ninja
+ dev-vcs/git
+ virtual/pkgconfig
+ )
+"
+
+python_prepare_all() {
+ # ASAN and sandbox both want control over LD_PRELOAD
+ # https://bugs.gentoo.org/673016
+ sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ if tc-is-gcc; then
+ # LTO fails for static libs because the bfd plugin in missing.
+ # Remove this workaround after sys-devel/gcc-config-2.0 is stable.
+ # https://bugs.gentoo.org/672706
+ tc-getPROG AR gcc-ar >/dev/null
+ fi
+ distutils-r1_src_test
+}
python_test() {
(