summaryrefslogtreecommitdiff
path: root/dev-util/meson/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /dev-util/meson/files
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'dev-util/meson/files')
-rw-r--r--dev-util/meson/files/0.48.0-multilib.patch48
-rw-r--r--dev-util/meson/files/0.48.0-test-u.patch28
-rw-r--r--dev-util/meson/files/test-llvm.patch26
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-util/meson/files/0.48.0-multilib.patch b/dev-util/meson/files/0.48.0-multilib.patch
deleted file mode 100644
index 0b488f50cd5b..000000000000
--- a/dev-util/meson/files/0.48.0-multilib.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 3bb300a76ed4d7a614c4a83ddefe86425040ec13 Mon Sep 17 00:00:00 2001
-From: Dylan Baker <dylan@pnwbakers.com>
-Date: Mon, 24 Sep 2018 11:08:19 -0700
-Subject: [PATCH] backends: allow running host arch binaries on compatible
- build machines
-
-Meson 0.48.0 some validation for using compiled binaries in custom
-targets and generators, which is nice. It didn't take into account
-though that as long as the OS is the same, some architectures support
-running a related architecture natively (x86_64 can run x86 natively,
-for example).
-
-Fortunately we already have a method for covering this case available
-through the Environment class.
-
-Fixes #4254
----
- mesonbuild/backend/backends.py | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/mesonbuild/backend/backends.py b/mesonbuild/backend/backends.py
-index 0e7e8e0fe3..ccbbe173fd 100644
---- a/mesonbuild/backend/backends.py
-+++ b/mesonbuild/backend/backends.py
-@@ -13,6 +13,7 @@
- # limitations under the License.
-
- import os, pickle, re
-+import textwrap
- from .. import build
- from .. import dependencies
- from .. import mesonlib
-@@ -731,10 +732,11 @@ def get_regen_filelist(self):
- def exe_object_to_cmd_array(self, exe):
- if self.environment.is_cross_build() and \
- isinstance(exe, build.BuildTarget) and exe.is_cross:
-- if self.environment.exe_wrapper is None:
-- s = 'Can not use target %s as a generator because it is cross-built\n'
-- s += 'and no exe wrapper is defined. You might want to set it to native instead.'
-- s = s % exe.name
-+ if self.environment.exe_wrapper is None and self.environment.cross_info.need_exe_wrapper():
-+ s = textwrap.dedent('''
-+ Can not use target {} as a generator because it is cross-built
-+ and no exe wrapper is defined or needs_exe_wrapper is true.
-+ You might want to set it to native instead.'''.format(exe.name))
- raise MesonException(s)
- if isinstance(exe, build.BuildTarget):
- exe_arr = [os.path.join(self.environment.get_build_dir(), self.get_target_filename(exe))]
diff --git a/dev-util/meson/files/0.48.0-test-u.patch b/dev-util/meson/files/0.48.0-test-u.patch
deleted file mode 100644
index 099d4686b963..000000000000
--- a/dev-util/meson/files/0.48.0-test-u.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 99ecedc0930a99fb4d084208964e4c7922a6efec Mon Sep 17 00:00:00 2001
-From: Masanori Kakura <kakurasan@gmail.com>
-Date: Tue, 25 Sep 2018 18:04:06 +0900
-Subject: [PATCH] environment: Use os.path.basename() when checking
- mesonlib.meson_command
-
-Without this, when one of Meson's parent directories contains
-"python", unexpected option "-u" will be passed to Meson.
----
- mesonbuild/environment.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mesonbuild/environment.py b/mesonbuild/environment.py
-index 7a44f2fd..a0c2fda4 100644
---- a/mesonbuild/environment.py
-+++ b/mesonbuild/environment.py
-@@ -375,7 +375,7 @@ class Environment:
-
- def get_build_command(self, unbuffered=False):
- cmd = mesonlib.meson_command[:]
-- if unbuffered and 'python' in cmd[0]:
-+ if unbuffered and 'python' in os.path.basename(cmd[0]):
- cmd.insert(1, '-u')
- return cmd
-
---
-2.19.0
-
diff --git a/dev-util/meson/files/test-llvm.patch b/dev-util/meson/files/test-llvm.patch
deleted file mode 100644
index af7b9834bf33..000000000000
--- a/dev-util/meson/files/test-llvm.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 40457b1faa2c5b274447838ff1a041a8030c6c22 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sat, 6 Oct 2018 21:11:36 -0400
-Subject: [PATCH] Disable testing of static llvm linkage
-
-Gentoo doesn't provide static libs for llvm.
----
- test cases/frameworks/15 llvm/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test cases/frameworks/15 llvm/meson.build b/test cases/frameworks/15 llvm/meson.build
-index e05fddd2..9b38a454 100644
---- a/test cases/frameworks/15 llvm/meson.build
-+++ b/test cases/frameworks/15 llvm/meson.build
-@@ -20,7 +20,7 @@ if not dep_tinfo.found()
- dep_tinfo = cpp.find_library('tinfo', required: false)
- endif
-
--foreach static : [true, false]
-+foreach static : [false]
- llvm_dep = dependency(
- 'llvm',
- modules : ['bitwriter', 'asmprinter', 'executionengine', 'target',
---
-2.19.0
-