summaryrefslogtreecommitdiff
path: root/dev-util/mdds/mdds-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-util/mdds/mdds-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-util/mdds/mdds-9999.ebuild')
-rw-r--r--dev-util/mdds/mdds-9999.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 1bede682c2d9..64e78d4d68f9 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
SLOT="1/${PV%.*}" # Check API version on version bumps!
-IUSE="doc valgrind test"
+IUSE="doc openmp valgrind test"
RESTRICT="!test? ( test )"
BDEPEND="
@@ -32,9 +32,16 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
default
-
eautoreconf
}
@@ -43,6 +50,11 @@ src_configure() {
$(use_enable doc docs)
$(use_enable valgrind memory_tests)
)
+ if use openmp && tc-has-openmp; then
+ myeconfargs+=( --enable-openmp )
+ else
+ myeconfargs+=( --disable-openmp )
+ fi
econf "${myeconfargs[@]}"
}