summaryrefslogtreecommitdiff
path: root/dev-util/mdds/mdds-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-util/mdds/mdds-1.5.0.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-util/mdds/mdds-1.5.0.ebuild')
-rw-r--r--dev-util/mdds/mdds-1.5.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-util/mdds/mdds-1.5.0.ebuild b/dev-util/mdds/mdds-1.5.0.ebuild
deleted file mode 100644
index 3b7f1556f29a..000000000000
--- a/dev-util/mdds/mdds-1.5.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
- inherit git-r3
-else
- SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-fi
-inherit autotools toolchain-funcs
-
-DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
-HOMEPAGE="https://gitlab.com/mdds/mdds"
-
-LICENSE="MIT"
-SLOT="1/${PV%.*}"
-IUSE="doc valgrind test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- doc? (
- app-doc/doxygen
- dev-python/sphinx
- )
- valgrind? ( dev-util/valgrind )
-"
-DEPEND="dev-libs/boost:="
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-buildsystem.patch" )
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable doc docs)
- $(use_enable valgrind memory_tests)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- tc-export CXX
-
- default
-}