summaryrefslogtreecommitdiff
path: root/dev-util/makeheaders/makeheaders-0_p4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/makeheaders/makeheaders-0_p4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/makeheaders/makeheaders-0_p4.ebuild')
-rw-r--r--dev-util/makeheaders/makeheaders-0_p4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/makeheaders/makeheaders-0_p4.ebuild b/dev-util/makeheaders/makeheaders-0_p4.ebuild
new file mode 100644
index 000000000000..0d4b0aa383c8
--- /dev/null
+++ b/dev-util/makeheaders/makeheaders-0_p4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple utility that will automatically generate header files"
+HOMEPAGE="http://www.hwaci.com/sw/mkhdr/"
+SRC_URI="
+ http://www.hwaci.com/sw/mkhdr/makeheaders.c -> ${P}.c
+ http://www.hwaci.com/sw/mkhdr/makeheaders.html -> ${P}.html"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${P}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ local HTML_DOCS=( "${DISTDIR}"/${P}.html )
+ einstalldocs
+}