summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/lxqt-build-tools
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest5
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild25
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild25
-rw-r--r--dev-util/lxqt-build-tools/metadata.xml11
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
new file mode 100644
index 000000000000..79b32a72b8c3
--- /dev/null
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -0,0 +1,5 @@
+DIST lxqt-build-tools-0.2.0.tar.xz 15552 BLAKE2B 558e1c9f43e09e51a720460592309f3f52fb7832a121ae40c8d9945ed135d6220190182a6d2311bfb9e9971f68a60f0ab7d5dcf2055301fa683dfc483170b3c6 SHA512 40349710a20d3f06761c57b5d40aa05cb194fa4b50d1e41e4bd7e6adf1beb5c7209f3d4965869a301369df17ec1d75f55aede7ab0fe88a55d692cd56d72121de
+DIST lxqt-build-tools-0.5.0.tar.xz 23392 BLAKE2B 1f28ae093af772ed2b6f75a7933b76a2c608171bf15e0c8483477d7f3b702dec79f41af70bb38863c3b17ff9d52a8f2acabd4ed2347bb7f421d2074b8767e96c SHA512 6802f3d5e3d622b136cf312ad929353aac1f42355c00ac9e3fb7a9d46c63dba1f87a0a4fd11185289c4e7222d5b0d30b8829dacd38c88de45901ff0559639e90
+EBUILD lxqt-build-tools-0.2.0.ebuild 503 BLAKE2B ce32303742984b29eca6a481df6f1a04e459c73661a6f7432404b5dff43fa83619dd2042ad690b03b333a2731e27e909e3d21c6668983e380d75f0ba4ae7ab30 SHA512 3d19db5002e4c194d0802226b617aee5901580286b298075fd563d9d38c76e83e9364900d8c82e6112939b1f8ea81efb2e050a2758f0b5935a862664311cd3d3
+EBUILD lxqt-build-tools-0.5.0.ebuild 508 BLAKE2B a1dda5bf87ffdeec4218646bc379483205aa5d471bf4c493079ee292297b38253cbdbf0bfae2703cc508a037c62e84e73edcc8d51083901c413887ffb450fb57 SHA512 3149c16f1b24e610e8223c5bc25480dd82ab222ba3ff06d856fbf0feb7b40eae95c55e0e9e27962e2e28477f2ca5eef8f3e0a6c717b8757bb7f1f923881677ee
+MISC metadata.xml 322 BLAKE2B 8b119aeafbe57841b2e072a7a009dd20383a752d6cce052c5b2e6c98c2341baad6e74fbb8798ffbf5c17719a37ff4d25efda922fcc32bf851b82e520af69777b SHA512 ffd6f030759c5c9e6f2aa42550a0de265550a03872c7b11c12ac4429a7dd1c3cbdb7cb470238273a313e9fcddbc5072b7dc4909811c4ab7609c0acc2e385a948
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild
new file mode 100644
index 000000000000..a28ed1dceef5
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-qt/qtcore:5"
+
+src_configure() {
+ cmake-utils_src_configure
+}
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
new file mode 100644
index 000000000000..97c50c2b4af0
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-util/lxqt-build-tools/metadata.xml b/dev-util/lxqt-build-tools/metadata.xml
new file mode 100644
index 000000000000..aa0b3609e965
--- /dev/null
+++ b/dev-util/lxqt-build-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-build-tools</remote-id>
+ </upstream>
+</pkgmetadata>