summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild')
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
new file mode 100644
index 000000000000..97c50c2b4af0
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/glib-2.50.0
+ dev-qt/qtcore:5
+"
+DEPEND="${RDEPEND}"