summaryrefslogtreecommitdiff
path: root/dev-util/lttng-modules/lttng-modules-2.12.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/lttng-modules/lttng-modules-2.12.8.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/lttng-modules/lttng-modules-2.12.8.ebuild')
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.12.8.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/lttng-modules-2.12.8.ebuild b/dev-util/lttng-modules/lttng-modules-2.12.8.ebuild
new file mode 100644
index 000000000000..674dde397d1a
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.12.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 3 0; then
+ eerror "${PN} require Linux kernel >= 3.0"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md TODO
+}