summaryrefslogtreecommitdiff
path: root/dev-util/ltrace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
commitb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (patch)
tree7d427f015930068f8d06e8f5aa622635ac3b61ca /dev-util/ltrace/files
parent4b61f038fc5ecca26609a997fcc662c7cf9e0498 (diff)
gentoo auto-resync : 14:08:2023 - 12:12:48
Diffstat (limited to 'dev-util/ltrace/files')
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch15
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-no-REG_NOERROR.patch50
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-no-error.h-2.patch72
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-no-error.h.patch36
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-pid_t.patch10
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-test-glibc-2.33.patch11
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-test-protos.patch71
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-tuple-tests.patch12
8 files changed, 0 insertions, 277 deletions
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch b/dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch
deleted file mode 100644
index fdd7412efeda..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/testsuite/ltrace.main/system_calls.exp
-+++ b/testsuite/ltrace.main/system_calls.exp
-@@ -29,8 +29,10 @@ if [regexp {ELF from incompatible architecture} $exec_output] {
- }
-
-
--set pattern "SYS_munmap"
--ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 2
-+## disabled in Gentoo: libc's stdio tends to call (or not to call) munmap
-+## depending on heuristics of stdio buffer sizes.
-+##set pattern "SYS_munmap"
-+##ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 2
- set pattern "SYS_write"
- ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 1
- set pattern "SYS_unlink"
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-no-REG_NOERROR.patch b/dev-util/ltrace/files/ltrace-0.7.3-no-REG_NOERROR.patch
deleted file mode 100644
index 7fc8b60aa48a..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-no-REG_NOERROR.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From b6c5c8c51f954cfbe76424fd57c33a87166f0545 Mon Sep 17 00:00:00 2001
-From: Petr Machata <pmachata@redhat.com>
-Date: Sat, 8 Dec 2012 03:23:39 +0100
-Subject: [PATCH] Avoid using REG_NOERROR
-
-Not all systems define this (IRIX 6.5 doesn't). Comparing to 0 is not
-terribly less readable, so do that instead.
----
- glob.c | 4 ++--
- options.c | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/glob.c b/glob.c
-index 9af633f..b26637f 100644
---- a/glob.c
-+++ b/glob.c
-@@ -180,7 +180,7 @@ glob_to_regex(const char *glob, char **retp)
- goto fail;
- }
- *retp = buf;
-- return REG_NOERROR;
-+ return 0;
- }
-
- int
-@@ -188,7 +188,7 @@ globcomp(regex_t *preg, const char *glob, int cflags)
- {
- char *regex = NULL;
- int status = glob_to_regex(glob, &regex);
-- if (status != REG_NOERROR)
-+ if (status != 0)
- return status;
- assert(regex != NULL);
- status = regcomp(preg, regex, cflags);
-diff --git a/options.c b/options.c
-index e8fd2a2..4c7441e 100644
---- a/options.c
-+++ b/options.c
-@@ -204,7 +204,7 @@ compile_libname(const char *expr, const char *a_lib, int lib_re_p,
-
- regex_t lib_re;
- int status = (lib_re_p ? regcomp : globcomp)(&lib_re, lib, 0);
-- if (status != REG_NOERROR) {
-+ if (status != 0) {
- char buf[100];
- regerror(status, &lib_re, buf, sizeof buf);
- fprintf(stderr, "Rule near '%s' will be ignored: %s.\n",
---
-2.25.2
-
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-no-error.h-2.patch b/dev-util/ltrace/files/ltrace-0.7.3-no-error.h-2.patch
deleted file mode 100644
index 6b798b274909..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-no-error.h-2.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 1233b37167097dffa9a78bd7bd0a8117c75fe8ff Mon Sep 17 00:00:00 2001
-From: Petr Machata <pmachata@redhat.com>
-Date: Sat, 8 Dec 2012 03:13:29 +0100
-Subject: [PATCH] expr_node_zero and expr_self should be stack-allocated
-
----
- expr.c | 14 ++++++--------
- zero.c | 14 ++++++--------
- 2 files changed, 12 insertions(+), 16 deletions(-)
-
---- a/expr.c
-+++ b/expr.c
-@@ -21,7 +21,6 @@
- #include <string.h>
- #include <assert.h>
- #include <errno.h>
--#include <error.h>
- #include <stdlib.h>
-
- #include "expr.h"
-@@ -327,12 +326,11 @@ expr_eval_constant(struct expr_node *node, long *valuep)
- struct expr_node *
- expr_self(void)
- {
-- static struct expr_node *node = NULL;
-- if (node == NULL) {
-- node = malloc(sizeof(*node));
-- if (node == NULL)
-- error(1, errno, "malloc expr_self");
-- expr_init_self(node);
-+ static struct expr_node *nodep = NULL;
-+ if (nodep == NULL) {
-+ static struct expr_node node;
-+ expr_init_self(&node);
-+ nodep = &node;
- }
-- return node;
-+ return nodep;
- }
---- a/zero.c
-+++ b/zero.c
-@@ -18,7 +18,6 @@
- * 02110-1301 USA
- */
-
--#include <error.h>
- #include <errno.h>
-
- #include "zero.h"
-@@ -93,13 +92,12 @@ build_zero_w_arg(struct expr_node *expr, int own)
- struct expr_node *
- expr_node_zero(void)
- {
-- static struct expr_node *node = NULL;
-- if (node == NULL) {
-- node = malloc(sizeof(*node));
-- if (node == NULL)
-- error(1, errno, "malloc expr_node_zero");
-- expr_init_cb1(node, &zero1_callback,
-+ static struct expr_node *nodep = NULL;
-+ if (nodep == NULL) {
-+ static struct expr_node node;
-+ expr_init_cb1(&node, &zero1_callback,
- expr_self(), 0, (void *)-1);
-+ nodep = &node;
- }
-- return node;
-+ return nodep;
- }
---
-2.25.2
-
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-no-error.h.patch b/dev-util/ltrace/files/ltrace-0.7.3-no-error.h.patch
deleted file mode 100644
index 56aea7a54d4d..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-no-error.h.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 86a7b48310e0fd551f7f3d88ea9ad39c1a2807c6 Mon Sep 17 00:00:00 2001
-From: Petr Machata <pmachata@redhat.com>
-Date: Sat, 8 Dec 2012 03:33:47 +0100
-Subject: [PATCH] Avoid using non-portable error.h in generic code
-
----
- read_config_file.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
---- a/read_config_file.c
-+++ b/read_config_file.c
-@@ -27,7 +27,6 @@
- #include <stdlib.h>
- #include <ctype.h>
- #include <errno.h>
--#include <error.h>
- #include <assert.h>
-
- #include "common.h"
-@@ -1258,8 +1257,11 @@ void
- init_global_config(void)
- {
- struct arg_type_info *info = malloc(2 * sizeof(*info));
-- if (info == NULL)
-- error(1, errno, "malloc in init_global_config");
-+ if (info == NULL) {
-+ fprintf(stderr, "Couldn't init global config: %s\n",
-+ strerror(errno));
-+ exit(1);
-+ }
-
- memset(info, 0, 2 * sizeof(*info));
- info[0].type = ARGTYPE_POINTER;
---
-2.25.2
-
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-pid_t.patch b/dev-util/ltrace/files/ltrace-0.7.3-pid_t.patch
deleted file mode 100644
index b54a5bf3a00c..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-pid_t.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/proc.h
-+++ b/proc.h
-@@ -26,6 +26,7 @@
- #include "config.h"
-
- #include <sys/time.h>
-+#include <unistd.h> /* pid_t */
-
- #if defined(HAVE_LIBUNWIND)
- # include <libunwind.h>
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-test-glibc-2.33.patch b/dev-util/ltrace/files/ltrace-0.7.3-test-glibc-2.33.patch
deleted file mode 100644
index 0b8592d82a1f..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-test-glibc-2.33.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/testsuite/ltrace.main/system_calls.exp
-+++ b/testsuite/ltrace.main/system_calls.exp
-@@ -55,7 +55,7 @@ set pattern "SYS_symlink"
- ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 1
- set pattern "SYS_unlink"
- ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 1
--set pattern "SYS_(new)?stat"
-+set pattern "SYS_(new)?stat|SYS_fstatat64|SYS_newfstatat"
- ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 1 egrep
- set pattern "SYS_access"
- ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 1
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-test-protos.patch b/dev-util/ltrace/files/ltrace-0.7.3-test-protos.patch
deleted file mode 100644
index caafff4b2637..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-test-protos.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-https://bugs.gentoo.org/421649
-
-For some reason testsuite does not handle warnings well:
- /tmp/lt-cZI2cFo0z7.c:2:24: warning: inplicit function declaration «puts» [-Wimplicit-function-declaration]
- void func2(void) { puts("func2"); }
- ^
-and abandons problematic tests:
- Testcase compile failed, so all tests in this file will automatically fail.
-diff --git a/testsuite/ltrace.main/filters.exp b/testsuite/ltrace.main/filters.exp
-index 988346f..f7f4140 100644
---- a/testsuite/ltrace.main/filters.exp
-+++ b/testsuite/ltrace.main/filters.exp
-@@ -24,2 +24,3 @@ set libfilt1 [ltraceCompile libfilt1.so [ltraceSource c {
- set libfilt2 [ltraceCompile libfilt2.so [ltraceSource c {
-+ #include <stdio.h>
- void func2(void) { puts("func2"); }
-diff --git a/testsuite/ltrace.main/parameters.c b/testsuite/ltrace.main/parameters.c
-index ff24a38..9569dbe 100644
---- a/testsuite/ltrace.main/parameters.c
-+++ b/testsuite/ltrace.main/parameters.c
-@@ -19,2 +19,3 @@ void func_strfixed(char*);
- void func_ppp(int***);
-+void func_string(char*);
- void func_stringp(char**);
-diff --git a/testsuite/ltrace.main/signals.c b/testsuite/ltrace.main/signals.c
-index a02e795..fda4ab9 100644
---- a/testsuite/ltrace.main/signals.c
-+++ b/testsuite/ltrace.main/signals.c
-@@ -7,2 +7,3 @@
- #include <sys/types.h>
-+#include <unistd.h>
-
-diff --git a/testsuite/ltrace.minor/time-record.c b/testsuite/ltrace.minor/time-record.c
-index a66b838..7d5e5e3 100644
---- a/testsuite/ltrace.minor/time-record.c
-+++ b/testsuite/ltrace.minor/time-record.c
-@@ -7,2 +7,3 @@
- #include <time.h>
-+#include <unistd.h>
-
-diff --git a/testsuite/ltrace.minor/trace-clone.c b/testsuite/ltrace.minor/trace-clone.c
-index db1936d..c68b128 100644
---- a/testsuite/ltrace.minor/trace-clone.c
-+++ b/testsuite/ltrace.minor/trace-clone.c
-@@ -10,2 +10,3 @@
- #include <sched.h>
-+#include <unistd.h>
-
-diff --git a/testsuite/ltrace.minor/trace-fork.c b/testsuite/ltrace.minor/trace-fork.c
-index c5f0c71..e1ab17f 100644
---- a/testsuite/ltrace.minor/trace-fork.c
-+++ b/testsuite/ltrace.minor/trace-fork.c
-@@ -8,2 +8,4 @@
- #include <sys/types.h>
-+#include <sys/wait.h>
-+#include <unistd.h>
-
-@@ -29,3 +31,4 @@ main ()
- printf("My child pid is %d\n",pid);
-- wait();
-+ int status;
-+ wait(&status);
- }
-diff --git a/testsuite/ltrace.torture/signals.c b/testsuite/ltrace.torture/signals.c
-index b786c81..86e2dba 100644
---- a/testsuite/ltrace.torture/signals.c
-+++ b/testsuite/ltrace.torture/signals.c
-@@ -7,2 +7,3 @@
- #include <sys/types.h>
-+#include <unistd.h>
-
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-tuple-tests.patch b/dev-util/ltrace/files/ltrace-0.7.3-tuple-tests.patch
deleted file mode 100644
index 9abeb28b4883..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-tuple-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Use $CC instead of gcc in testsuite.
---- a/testsuite/Makefile.am
-+++ b/testsuite/Makefile.am
-@@ -39,6 +39,8 @@ env.exp: Makefile
- rm -f env.exp
- echo set libelf_LD_LIBRARY_PATH '"$(libelf_LD_LIBRARY_PATH)"' >> $@
- echo set libunwind_LD_LIBRARY_PATH '"$(libunwind_LD_LIBRARY_PATH)"' >> $@
-+ echo set CC_FOR_TARGET '"$(CC)"' >> $@
-+ echo set CXX_FOR_TARGET '"$(CXX)"' >> $@
-
- CLEANFILES = *.o *.so *.log *.sum *.ltrace site.bak setval.tmp site.exp env.exp
-