summaryrefslogtreecommitdiff
path: root/dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild')
-rw-r--r--dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild b/dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild
new file mode 100644
index 000000000000..578352422417
--- /dev/null
+++ b/dev-util/log4shelldetect/log4shelldetect-0.0.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="check for java programs vulnerable to log4shell"
+HOMEPAGE="https://github.com/1lann/log4shelldetect"
+SRC_URI="https://github.com/1lann/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build .
+}
+
+src_install() {
+dobin log4shelldetect
+dodoc README.md
+}