summaryrefslogtreecommitdiff
path: root/dev-util/libtree/libtree-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-util/libtree/libtree-2.0.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-util/libtree/libtree-2.0.0.ebuild')
-rw-r--r--dev-util/libtree/libtree-2.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/libtree/libtree-2.0.0.ebuild b/dev-util/libtree/libtree-2.0.0.ebuild
new file mode 100644
index 000000000000..a9152d7fe064
--- /dev/null
+++ b/dev-util/libtree/libtree-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/cxxopts
+ dev-cpp/elfio
+ dev-cpp/termcolor
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBTREE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}