summaryrefslogtreecommitdiff
path: root/dev-util/librnp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /dev-util/librnp/files
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'dev-util/librnp/files')
-rw-r--r--dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch b/dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch
new file mode 100644
index 000000000000..4e8b67a2f5f7
--- /dev/null
+++ b/dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch
@@ -0,0 +1,36 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2023-05-02 11:01:48.000000000 +0300
++++ b/CMakeLists.txt 2023-05-03 11:57:06.095299932 +0300
+@@ -176,11 +176,6 @@
+ endif()
+ add_subdirectory(src/common)
+
+-set(WITH_SEXP_CLI OFF)
+-set(WITH_SEXP_TESTS OFF)
+-set(CMAKE_INSTALL_DEFAULT_COMPONENT_NAME development)
+-add_subdirectory(src/libsexp EXCLUDE_FROM_ALL)
+-
+ add_subdirectory(src/lib)
+ add_subdirectory(src/rnp)
+ add_subdirectory(src/rnpkeys)
+diff -Naur a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
+--- a/src/lib/CMakeLists.txt 2023-05-02 11:01:48.000000000 +0300
++++ b/src/lib/CMakeLists.txt 2023-05-03 10:59:25.147032470 +0300
+@@ -433,7 +433,7 @@
+ COMPONENT development
+ )
+
+- install(TARGETS librnp-static sexp
++ install(TARGETS librnp-static
+ EXPORT rnp-targets
+ ARCHIVE
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+@@ -441,7 +441,7 @@
+ )
+ else(BUILD_SHARED_LIBS)
+ # static libraries only
+-install(TARGETS librnp sexp
++install(TARGETS librnp
+ EXPORT rnp-targets
+ ARCHIVE
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}"