summaryrefslogtreecommitdiff
path: root/dev-util/lcov/lcov-1.13-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/lcov/lcov-1.13-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/lcov/lcov-1.13-r1.ebuild')
-rw-r--r--dev-util/lcov/lcov-1.13-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/lcov/lcov-1.13-r1.ebuild b/dev-util/lcov/lcov-1.13-r1.ebuild
new file mode 100644
index 000000000000..8baf9478f95f
--- /dev/null
+++ b/dev-util/lcov/lcov-1.13-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
+HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
+SRC_URI="mirror://sourceforge/ltp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/GD[png]"
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
+}