summaryrefslogtreecommitdiff
path: root/dev-util/kup/kup-0.3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/kup/kup-0.3.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/kup/kup-0.3.4-r1.ebuild')
-rw-r--r--dev-util/kup/kup-0.3.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/kup/kup-0.3.4-r1.ebuild b/dev-util/kup/kup-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..54b8b1a1e82a
--- /dev/null
+++ b/dev-util/kup/kup-0.3.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="kernel.org uploader tool"
+HOMEPAGE="https://www.kernel.org/pub/software/network/kup"
+SRC_URI="mirror://kernel/software/network/kup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/BSD-Resource
+ dev-perl/Config-Simple
+"
+
+DOCS=( README )
+
+src_install() {
+ dobin "${PN}" "${PN}-server" gpg-sign-all
+ doman "${PN}.1"
+ einstalldocs
+}