summaryrefslogtreecommitdiff
path: root/dev-util/kcov/kcov-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/kcov/kcov-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/kcov/kcov-9999.ebuild')
-rw-r--r--dev-util/kcov/kcov-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/kcov/kcov-9999.ebuild b/dev-util/kcov/kcov-9999.ebuild
new file mode 100644
index 000000000000..eec056058ef3
--- /dev/null
+++ b/dev-util/kcov/kcov-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
+HOMEPAGE="https://github.com/SimonKagstrom/kcov"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [ "${PV}" -eq 9999 ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SimonKagstrom/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/SimonKagstrom/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ dev-libs/elfutils
+ net-misc/curl
+ sys-devel/binutils:*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"