summaryrefslogtreecommitdiff
path: root/dev-util/kcov/kcov-40.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/kcov/kcov-40.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/kcov/kcov-40.ebuild')
-rw-r--r--dev-util/kcov/kcov-40.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/kcov/kcov-40.ebuild b/dev-util/kcov/kcov-40.ebuild
new file mode 100644
index 000000000000..963a9c930a5e
--- /dev/null
+++ b/dev-util/kcov/kcov-40.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
+HOMEPAGE="https://github.com/SimonKagstrom/kcov"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/SimonKagstrom/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/SimonKagstrom/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+binutils"
+
+RDEPEND="dev-libs/elfutils
+ net-misc/curl
+ sys-libs/zlib
+ binutils? ( sys-libs/binutils-libs:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Bfd=$(usex !binutils)
+
+ -DKCOV_INSTALL_DOCDIR=share/doc/${PF}
+ )
+
+ cmake_src_configure
+}