summaryrefslogtreecommitdiff
path: root/dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
commitbf99f8024d68382f76665735c70ae912331bc2ca (patch)
tree6fa5830f88fa9ddb794b019c25b83a76ec410df4 /dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild
parentc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (diff)
gentoo auto-resync : 04:10:2022 - 07:16:51
Diffstat (limited to 'dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild')
-rw-r--r--dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild b/dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild
new file mode 100644
index 000000000000..8f8fecf94d4b
--- /dev/null
+++ b/dev-util/jfrog-cli/jfrog-cli-2.27.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Command line utility for operations on container images and image repositories"
+HOMEPAGE="https://github.com/jfrog/jfrog-cli"
+SRC_URI="https://github.com/jfrog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ build/build.sh jfrog || die
+}
+
+src_install() {
+ dobin jfrog
+ einstalldocs
+}