summaryrefslogtreecommitdiff
path: root/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild')
-rw-r--r--dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild b/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
deleted file mode 100644
index fdf2132e3533..000000000000
--- a/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-MY_P=${PN//-/_}_2012_x64
-
-inherit rpm multilib
-
-INTEL_CL=usr/$(get_libdir)/OpenCL/vendors/intel/
-
-DESCRIPTION="Intel's implementation of the OpenCL standard optimized for Intel processors"
-HOMEPAGE="http://software.intel.com/en-us/articles/opencl-sdk/"
-SRC_URI="http://registrationcenter.intel.com/irc_nas/2563/intel_sdk_for_ocl_applications_2012_x64.tgz"
-
-LICENSE="Intel-SDP"
-SLOT="0"
-IUSE="tools"
-KEYWORDS="amd64 -x86"
-
-RDEPEND="app-eselect/eselect-opencl
- dev-cpp/tbb
- sys-process/numactl
- tools? (
- sys-devel/llvm
- >=virtual/jre-1.6
- )"
-DEPEND=""
-
-RESTRICT="mirror"
-QA_EXECSTACK="${INTEL_CL/\//}libcpu_device.so
- ${INTEL_CL/\//}libOclCpuBackEnd.so
- ${INTEL_CL/\//}libtask_executor.so"
-QA_PREBUILT="${INTEL_CL}*"
-
-S=${WORKDIR}
-
-src_unpack() {
- default
- rpm_unpack ./${MY_P}.rpm
-}
-
-src_prepare() {
- # Remove unnecessary and bundled stuff
- rm -rf ${INTEL_CL}/{docs,version.txt,llc}
- rm -f ${INTEL_CL}/libboost*.so
- rm -f ${INTEL_CL}/libtbb*
- if ! use tools; then
- rm -rf usr/bin
- rm -f ${INTEL_CL}/{ioc64,ioc.jar}
- rm -f ${INTEL_CL}/libboost*
- fi
-}
-
-src_install() {
- doins -r etc
-
- insinto ${INTEL_CL}
- doins -r usr/include
-
- insopts -m 755
- newins usr/$(get_libdir)/libOpenCL.so libOpenCL.so.1
- dosym libOpenCL.so.1 ${INTEL_CL}/libOpenCL.so
-
- doins ${INTEL_CL}/*
-}
-
-pkg_postinst() {
- eselect opencl set --use-old intel
-}