summaryrefslogtreecommitdiff
path: root/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch')
-rw-r--r--dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch b/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch
new file mode 100644
index 000000000000..6abfdfe60d53
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.10713-allow-external-spirv-tools-fix-static.patch
@@ -0,0 +1,23 @@
+From 7e6b78d1ccf5afb4080795aa87029e55b9e5499c Mon Sep 17 00:00:00 2001
+From: Andrey Agrachev <andrey.agrachev@intel.com>
+Date: Thu, 10 Mar 2022 12:51:37 +0000
+Subject: [PATCH] Remove 'static' suffix
+
+Remove 'static' suffix to enable shared lib usage
+---
+ external/SPIRV-Tools/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/external/SPIRV-Tools/CMakeLists.txt b/external/SPIRV-Tools/CMakeLists.txt
+index f46a6988683..f40605c4b36 100644
+--- a/external/SPIRV-Tools/CMakeLists.txt
++++ b/external/SPIRV-Tools/CMakeLists.txt
+@@ -34,7 +34,7 @@ if(IGC_OPTION__SPIRV_TOOLS_MODE STREQUAL PREBUILDS_MODE_NAME)
+
+ set(INCLUDE_DIRS_LIST "${SPIRV-Tools_ROOT_DIR}/include" "${SPIRV-Headers_INCLUDE_DIR}")
+ set_target_properties(SPIRV-Tools-static PROPERTIES INCLUDE_DIRECTORIES "${INCLUDE_DIRS_LIST}")
+- set(IGC_BUILD__PROJ__SPIRV-Tools SPIRV-Tools-static)
++ set(IGC_BUILD__PROJ__SPIRV-Tools SPIRV-Tools)
+
+ else() #By default use build from sources
+ message(STATUS "[SPIRV-Tools] : IGC_OPTION__SPIRV_TOOLS_MODE set to Source")