summaryrefslogtreecommitdiff
path: root/dev-util/indent/indent-2.2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-util/indent/indent-2.2.12.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-util/indent/indent-2.2.12.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.12.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/indent/indent-2.2.12.ebuild b/dev-util/indent/indent-2.2.12.ebuild
index ab0455d550ad..a3c8834d1a88 100644
--- a/dev-util/indent/indent-2.2.12.ebuild
+++ b/dev-util/indent/indent-2.2.12.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit l10n
DESCRIPTION="Indent program source files"
HOMEPAGE="https://www.gnu.org/software/indent/"
@@ -13,9 +14,9 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="nls"
-DEPEND="
- nls? ( sys-devel/gettext )
+BDEPEND="
app-text/texi2html
+ nls? ( sys-devel/gettext )
"
RDEPEND="
nls? ( virtual/libintl )
@@ -23,7 +24,6 @@ RDEPEND="
src_prepare() {
default
-
sed -i -e '/AM_CFLAGS/s:-Werror::g' src/Makefile.{am,in} || die
}
@@ -47,5 +47,5 @@ src_test() {
src_install() {
# htmldir as set in configure is ignored in doc/Makefile*
emake DESTDIR="${D}" htmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
- dodoc AUTHORS NEWS README.md ChangeLog ChangeLog-1990 ChangeLog-1998 ChangeLog-2001
+ dodoc AUTHORS NEWS README.md ChangeLog{,-1990,-1998,-2001}
}