summaryrefslogtreecommitdiff
path: root/dev-util/indent/indent-2.2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-util/indent/indent-2.2.12.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-util/indent/indent-2.2.12.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/indent/indent-2.2.12.ebuild b/dev-util/indent/indent-2.2.12.ebuild
new file mode 100644
index 000000000000..a8d9e29f1f6b
--- /dev/null
+++ b/dev-util/indent/indent-2.2.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="https://www.gnu.org/software/indent/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="
+ nls? ( sys-devel/gettext )
+ app-text/texi2html
+"
+RDEPEND="
+ nls? ( virtual/libintl )
+"
+
+src_prepare() {
+ default
+
+ sed -i -e '/AM_CFLAGS/s:-Werror::g' src/Makefile.{am,in} || die
+}
+
+src_configure() {
+ strip-linguas -i po/
+
+ gl_cv_cc_vis_werror=no econf $(use_enable nls)
+}
+
+src_test() {
+ emake -C regression/
+}
+
+src_install() {
+ # htmldir as set in configure is ignored in doc/Makefile*
+ emake DESTDIR="${D}" htmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dodoc AUTHORS NEWS README.md ChangeLog ChangeLog-1990 ChangeLog-1998 ChangeLog-2001
+}