summaryrefslogtreecommitdiff
path: root/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild')
-rw-r--r--dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild b/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
new file mode 100644
index 000000000000..8edb2a36308e
--- /dev/null
+++ b/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml'
+
+inherit eutils python-r1
+
+MY_PV=0_p${PV//./}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Converts profiling output to dot graphs"
+HOMEPAGE="https://github.com/jrfonseca/gprof2dot"
+SRC_URI="http://www.hartwork.org/public/${MY_P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${MY_P}-py3-xrange.patch
+}
+
+_make_call_script() {
+ cat <<-EOF >"${ED}/$1"
+ #! /usr/bin/env python
+ from gprof2dot import Main
+ Main().main()
+ EOF
+
+ fperms a+x "$1" || die
+}
+
+src_install() {
+ abi_specific_install() {
+ local sitedir="$(python_get_sitedir)"
+ insinto ${sitedir#"${EPREFIX}"}
+ doins ${PN}.py || die
+ python_optimize || die
+ }
+ python_foreach_impl abi_specific_install
+
+ dodir /usr/bin || die
+ _make_call_script /usr/bin/${PN} || die
+ python_replicate_script "${ED}"/usr/bin/${PN} || die
+}