summaryrefslogtreecommitdiff
path: root/dev-util/gn/gn-0.1479.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
commitaa3411e241a201d53a2689766fe419f2756819f3 (patch)
treecc19adfde0a10aab1ab566c8dfe3c1616e5cc390 /dev-util/gn/gn-0.1479.ebuild
parentb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (diff)
gentoo resync : 24.03.2019
Diffstat (limited to 'dev-util/gn/gn-0.1479.ebuild')
-rw-r--r--dev-util/gn/gn-0.1479.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gn/gn-0.1479.ebuild b/dev-util/gn/gn-0.1479.ebuild
deleted file mode 100644
index 89fd565c9595..000000000000
--- a/dev-util/gn/gn-0.1479.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit ninja-utils python-any-r1 toolchain-funcs
-
-DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
-HOMEPAGE="https://gn.googlesource.com/"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="vim-syntax"
-
-BDEPEND="
- ${PYTHON_DEPS}
- dev-util/ninja
-"
-
-PATCHES=(
- "${FILESDIR}"/gn-gen-r2.patch
- "${FILESDIR}"/gn-numerics-arm.patch
-)
-
-pkg_setup() {
- :
-}
-
-src_configure() {
- python_setup
- tc-export AR CC CXX
- unset CFLAGS
- set -- ${EPYTHON} build/gen.py --no-sysroot --no-last-commit-position
- echo "$@"
- "$@" || die
- cat >out/last_commit_position.h <<-EOF || die
- #ifndef OUT_LAST_COMMIT_POSITION_H_
- #define OUT_LAST_COMMIT_POSITION_H_
- #define LAST_COMMIT_POSITION "${PV}"
- #endif // OUT_LAST_COMMIT_POSITION_H_
- EOF
-}
-
-src_compile() {
- eninja -C out gn
-}
-
-src_test() {
- eninja -C out gn_unittests
- out/gn_unittests || die
-}
-
-src_install() {
- dobin out/gn
- einstalldocs
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r tools/gn/misc/vim/{autoload,ftdetect,ftplugin,syntax}
- fi
-}