summaryrefslogtreecommitdiff
path: root/dev-util/glslang/glslang-1.3.250.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 08:19:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 08:19:18 +0100
commit4d0ca679fbcb59301ffc7af98794c411c5061a0b (patch)
tree8353718f79e0de6c7c5ee2d6cab498bd3bebf565 /dev-util/glslang/glslang-1.3.250.ebuild
parent683e8a42fb208dee0d6289d084fb39ab17aa2b60 (diff)
gentoo auto-resync : 12:06:2023 - 08:19:18
Diffstat (limited to 'dev-util/glslang/glslang-1.3.250.ebuild')
-rw-r--r--dev-util/glslang/glslang-1.3.250.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-1.3.250.ebuild b/dev-util/glslang/glslang-1.3.250.ebuild
new file mode 100644
index 000000000000..0ddc071bafdc
--- /dev/null
+++ b/dev-util/glslang/glslang-1.3.250.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SNAPSHOT_COMMIT="sdk-${PV}.0"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${SNAPSHOT_COMMIT}"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0/12"
+
+# Bug 698850
+RESTRICT="test"
+
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.236-Install-static-libs.patch" )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PCH=OFF
+ )
+ cmake_src_configure
+}